Atualizando node.js no Ubuntu / ElementaryOS

Publicado em

Ao instalar Ghost, me deparei com um problema - precisava de uma versão mais recente do Node.

Vi este artigo que ensina a atualizar a versão do Node.js. Me quebrou um galhão.

ERROR: Unsupported version of Node 
Ghost needs Node version >=0.10.* <0.11.4 you are using version 0.9.9 
Please go to http://nodejs.org to get the latest version
jnaves@skynet:~/Projects/ghost$ sudo n
[sudo] password for jnaves: 
jnaves@skynet:~/Projects/ghost$ sudo npm cache clean -f
[sudo] password for jnaves: 
jnaves@skynet:~/Projects/ghost$ sudo npm install -g n
npm http GET https://registry.npmjs.org/n
npm http 200 https://registry.npmjs.org/n
npm http GET https://registry.npmjs.org/n/-/n-1.1.0.tgz
npm http 200 https://registry.npmjs.org/n/-/n-1.1.0.tgz
/usr/local/bin/n -> /usr/local/lib/node_modules/n/bin/n
n@1.1.0 /usr/local/lib/node_modules/n
jnaves@skynet:~/Projects/ghost$ sudo n stable

     install : 0.10.20
       mkdir : /usr/local/n/versions/0.10.20
       fetch : http://nodejs.org/dist/v0.10.20/node-v0.10.20-linux-x64.tar.gz
/usr/local/bin/node
   installed : v0.10.20

jnaves@skynet:~/Projects/ghost$ node -v
v0.10.20

\o/

 _              _           
| | ___   _  __| | ___  ___ 
| |/ / | | |/ _` |/ _ \/ __|
|   <| |_| | (_| | (_) \__ \
|_|\_\\__,_|\__,_|\___/|___/

Sobre o Blog do Neto

Blog do Neto é o espaço na internê onde eu publico tutoriais, dicas e novidades sobre programação - mais notavelment Android, Java e Linux.